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What’s Changing? 
Student Clubs and Organizations will now use the Cascade Content Management System 

(“Cascade CMS” or “CMS”) to edit their websites instead of the legacy systems. This will allow 

editing of club websites through the my.scranton portal and consistent branding across all 

University of Scranton websites. 

The old club websites at http://academic.scranton.edu/organizations/ will be shut down once you 

have activated your club’s new website at http://matrix.scranton.edu/student-clubs/ using the 

CMS. Fortunately, the CMS makes transfer of your existing content to the new website fairly 

simple. 

The Office of Student Government stands ready to assist you with this process. Please be sure to 

check out our website at www.scranton.edu/sg for more information on this initiative (Click on 

the “Club Websites” link on the “Clubs” menu). For more information and support requests, 

please contact Director of Technology Fred Fuchs at fuchsf2@scranton.edu. 

Technical Documentation 
Technical documentation provided by the University’s Department of Information Technology is 

included in this document after the “Student Club/Organization Website Policies” section. 

Please note that in order to initially publish or make changes to your organization’s website, you 

must fill out the “Request Student Club/Organization Website Publication” form on the Student 

Government website under “Clubs -> Club Websites.” 

Student Club/Organization Website Policies  
Club websites must adhere to The University of Scranton Student Computing Policy, 

Community Standards Code, applicable laws and regulations, and the Student Government Club 

and Organizations handbook and policies. This includes, but is not limited to, a prohibition on 

fraud, forgery, harassment, extortion, threats, copyright violation, and sexually explicit content. 

For purposes of maintaining the value of the Scranton brand on the web, clubs and organizations 

are also required to maintain their websites consistent with The University of Scranton Web 

Style Guide and Web Guidelines. Copies of this and other policies are available on the Student 

Government website. 

Any questions on these policies should be referred to the Student Government Director of 

Technology. 

http://academic.scranton.edu/organizations/
http://matrix.scranton.edu/student-clubs/
http://www.scranton.edu/sg
mailto:fuchsf2@scranton.edu


CMS BASICS 
 

1) How do I access to the CMS?  

Log into the My.Scranton portal and then click on the CMS icon. The Content 

Management System will open in a new window. 

 

2) Where is my folder located? 

If the folder matrix.scranton.edu is not expanded, click the plus 

sign  to expand the folder tree. Next, click the  in front of 

your department‟s folder and then on the page you intend to edit. 

Once the page displays you will use Cascade's built-in word 

processor to update and remove existing content. This includes 

adding images, linking to other web pages, etc. 

 

3) How do I use the Cascade Editor? 

When the selected page loads, the content opens in Layout view 

displaying a page icon in the top left corner of each region on a 

page. The icon represents the grouping of several items together 

including content, template, blocks and more.  

 

 

 

Enclosed is a basic description of the processing tools available in the content window. Most 

of the tools are similar to those used in Word and provide a tooltip with a mouse over. This 

documentation will review the more uncommon tools.  

 

 – The View tab opens and displays the selected page in Layout view. To preview the 

page before submitting and without the icon click the Preview pane on the View tab.   
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 – To add or edit content within the current document click the Edit tab to open the 

editor.  

 

 - The Paste from Word icon opens a content box to paste text from a word processing 

application. It is very important not to copy and paste text directly from Word into 

the workspace. Word often retains formatting („, “,) that cannot be recognized or cleaned 

using the tools in the CMS editor.  

To prevent this: 

1. Copy and paste the text from Word into Notepad. 

2. Next, copy and paste the text from Notepad into the workspace. 

OR 

Click on the Paste from Word icon and paste the text from Word in the content box. 

Click the Insert button to add the text. 

Quick Tip - Add Notepad to your Start menu.  

How to: Click on the menus Start, All Programs, Accessories, and then Notepad. Right 

click on Notepad and choose "Pin to Start menu". 

 - Find/Replace text within the selected page, especially useful when replacing an 

overused word. 

 − Icons used to add/edit or remove hyperlinks from selected text or a picture.   

 

Internal URL‟s 

 

1. Select the text to be used for the 

hyperlink and then click on the 

Insert/edit Link icon. 

2. Click on the Browse icon next 

the label Link. 
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Choose a File or Page from the new 

window. 

 

3. Before clicking on 

Confirm verifiy that the 

path is correct. The example shows that the page is located within a sub-folder “new-

sandbox” of the folder sandbox. 

 

4. Set the Target to open either in the Same Window or a New Window (new browser 

window).  Click Update. When finished editing Submit the page. 

 

 

External URL‟s 

How to:  

1. Copy the desire URL (web 

address) to the Clipboard. 

2. Select the text to be used for the 

hyperlink.  

3. Click on the icon shown above 

as a solid link. 

4. Paste the URL of the desired 

page in the Insert/Edit Link box. 

5. Click on the drop down arrow to set the target to open in New Window. 

 − Icon used to insert/edit anchors (a hyperlink destination) inside a web page or to link 

to a specific location within another page. 

      How to Insert and Use Anchor 

For Example: 

1. In Edit view highlight one or 

mores words of text at the end of 

the last paragraph or press the 

Enter key and type The End. 

2. Click on the Insert/edit icon. Type a name (tend) for the anchor (use abbreviated 

lowercase naming conventions with no spaces, underscores, or periods). 
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3. Click Update to add the 

anchor. 

4. At the end of the first 

paragraph highlight one or 

more words or type For more 

information… 

5. Click on the add/edit 

hyperlink icon and type the 

name of the anchor (tend) in 

the box provided. 

6. Click Update and then Submit.  

       

Linking a web page to the Anchor used in another page 

Before you begin!!! Using an anchor to link to a specific loaction in another page requires 

that page is in your department folder. You can not use this method to link to a specific 

location in another department‟s web page. 

How to: 

1. In the prior example you learned how to insert an anchor in a web page.  If you 

skipped the example follow instructions 1 and 2 before proceeding. Remember the 

name of the anchor and to 

spell in correctly later. 

Click Submit . 

2. Open the department 

document that will 

hyperlink to the anchor.. 

3. Click on the tab Edit.  

4. Highlight one or more 

words or type For more 

information… 

5. Click on the add/edit hyperlink icon and then click the Browse icon to locate page 

with the named anchor (tend). 

6. Type the anchor‟s name in the box provided then click Update. Click Submit. 



5 

 

How do I create a subfolder within my department folder? 

How to:  

a. In the left pane click on your department's folder. 

b. From the main menu click on New, your department folder, and then click on 

New Folder. 

c. In the box labeled System Name, name the folder and then click Submit.  

Remember: Folder file names should not consist of any spaces or underscores ( _ ), with the 

exception of dashes ( - ). 

 

  − Icon used to insert/edit images.  

Important: Images should be a JPG or BMP file (ie: image.jpg, filename.bmp). If the image is a 

GIF, TIFF, or not uploading properly, please convert the image to a JPG. 

 

Add an image to your department‟s image folder. 

How to:  

1. In the left pane click on your department folder and 

then the image folder. 

 

2. Click on the top navigation menus New | Default | 

File.  

3. When the New File content pane opens scroll to the 

menu File Upload.  

4. Click the Browse button and navigate to 

the desired image. 

5. Click Submit to upload the image. 

Opps! a mistake was made and the image was placed in the department folder and not the  

image folder.  
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Moving an image to the designated folder 

How to:  

1. Locate the picture 

to move in the left 

navigation pane. 

2. Click on the 

picture's name to 

view the image in 

the right content 

pane. 

3. Click on the tab Edit and then the submenu System. Click on the Browse icon next to 

the label Parent Folder and then click your department‟s folder Images. 

4. Click on the folder images and then the button Confirm.  

Note the path! If you were working in your department folder the path would be the 

department's folder name/images. 

 

 

 

 

 

 

 

 

 

 

5. Click the button Submit after reviewing 

the new location. 
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Upload Multiple Pictures by Importing a Zip Archive 

A zip archive consists of multiple files or pictures that were packaged together in a folder. To 

create a zip archive in Windows XP right click on any folder. From the side menu choose the 

menus Send To and then Compressed (zipped Folder). The file 

is now ready to import. 

 

Remember: Folder file names should not consist of any spaces or underscores ( _ ), with the 

exception of dashes ( - ). 

 

How to import: 

1. Click on the top navigation menus Tools | Import | 

Zip Archive 

2. Click Browse and then select the Zip Archive to upload. 

3. Choose the Folder. 

4. Press Submit. 

 

Insert an image in the content pane. 

 How to:  

1. In the Edit pane place the mouse 

cursor within the content. 

2. Click on the Picture Insert icon to open the Insert/Edit Image box. 

3. Click on the Browse icon and then navigate to the departments image folder and 

select the image. 

4. Add the Alternate Text for screen readers. Click on Update and then Submit 

 

 − Icon used to insert a horizontal line. 

− Toggle to view and edit the current page in code view. 

 - Toggle the current view to full screen mode. 

When you are finished modifying the document, click on the button Submit. 

Note: Clicking on the Submit button does not Publish the document to the web! To publish 

requires the designated role as Publisher who in turn clicks on the tab Publish and then the 

Submit button. 
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 – click this tab to make a copy of your 

document. 

 – click this tab and then the button 

Submit to publish your document to the web. 

Note:  only users who are assigned Publishing 

privileges will see this tab. 

 

 

 

 

4) What are Messages on the Home menu? 

To check messages click on Home in the upper left corner 

Click on the envelopes beneath My Messages to open the 

Message pane. 

 

5) How are Messages used? 

 To inform a user regarding locked content or workflow steps. 

 To make notifications of error messages 

 To set alerts and review dates for expiring content. 

 

6) What is Versioning? 

Cascade automatically saves a version every time changes are submitted. This allows the user 

to revert to a prior version at any time by making the selected version the current version. 

 

How to:  

1. Select a page and then click on the tab Advanced. 

2. Choose Versions from the drop-down menu. 

3. Click on the version you want to view, and it will open in the main view displaying 

what the asset looked like at that point and time. 

4. You will see an added "viewing" bar, allowing you to select the following actions:  
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Newer - Advances to a later version. 

Older - Scrolls through to an earlier version. 

Current - Reverts to the active or current version. 

Activate - Makes the currently viewed version the active or current version.  

Note: Making the currently viewed version the current version does not eliminate the 

prior current version. It becomes a version also allowing the user to undo the 

Activate. 

 

Delete – Deletes the currently viewed version from the versions list. 

Compare with Current – Displays the difference between the version you are 

currently viewing and the active version. Changes are indicated with a striking 

through deleted text and highlighting newly added text. 

 

7) How do I access specific help for the area I am working?  

Click on the question mark in the upper right hand corner of the content pane.  

 

8) How do I get Technical Support for the CMS? 

Enter a Project Tracking Request via the MyScranton portal. 
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